Archive for December, 2007

Gambas 1.9.92 op openSuse 10.3 install (log)

Installatie van huidige versie op vers-ge├»nstalleerde openSuse waar geen extra “installatiebronnen” aan werden toegevoegd. Gelukt mits aantal meldingen van onderdelen die voor standaard werk waarschijnlijk niet nodig zijn. De meeste voorbeelden werken, gambasgears (opengl), en sound (gb.sdl.sound) niet, database nog uit te proberen. Volledig log hieronder:
Open Suse 10.3 met alle updates tot […]

Formulier bestand fout (gambas 1.9.33)

Gambas 2 is nog in ontwikkeling, maar nadert de stabiele versie. Met versienummer 1.9.x kan je nog problemen tegenkomen die soms in meer recente versies zijn opgelost. Onderstaand is daar waarschijnlijk een voorbeeld van:
Bij het een bestaand project heb ik het volgende probleem:
- bij het openen van de Main form: een foutmelding […]

Gambas: compiler, interpreter, archiver

Schema van de werking:

Compiler: gbc

Interpreter: gbx

Archiver: gba

De projectdirectory bevat alles wat de compiler nodig heeft, als beeldbestanden, broncode van de modules en classes, . De applicatie wordt vanuit de ide rechstreeks uitgevoerd. Er worden een aantal onzichtbare bestanden gemaakt, plus een directory met de naam .gambas. De bestanden zijn:
.directory
.icon.png
.settings
.lock
.project
.lock […]

Gambas 1+2 installatie op Suse 10.0 (log)

Niet al te best gelukt. Ik keek voor de “dependencies” of “afhankelijkheden” met de beschreven installatie op openSuse 10.2, en installeerde in het bestaand systeem al de beschreven packages.
De download link
ftp://ftp.gwdg.de/pub/linux/misc/suser-gbv/rpms/
komt van
http://gambas.sourceforge.net/download.html
en leidt naar
ftp://ftp.gwdg.de/pub/linux/misc/suser-gbv/rpms/SuSE_10.0 (*)
(*) Opgelet: deze versie is niet aan te raden! Zie bugs. Installeer een meer recente versie, desnoods […]

Installatie van Gambas 1.9.91 op KUbuntu (log)

Log van een installatie van huidige Gambas 1.9.91 op huidige KUbuntu 7.10 Gutsy Gibbon (lijkt ok -upd: probl met MySql: error “unable to set database charset” - in latere versies wordt dit een warning - ondertussen bestaan recentere versies van Gambas!):
Controleren van de nodige “dependencies”: in principe kan dat met sudo apt-get install (namen van […]

VFP: Einde van de vos, begin van de Gambas?

In dit bericht
http://blogs.msdn.com/yag/archive/2007/03/13/message-to-the-vfp-community.aspx
werd aangekondigd dat er geen nieuwe versie zou verschijnen van Visual Foxpro.
De laatste versie was VFP 9, en die zou ondersteund blijven tot 2015, maar er komt geen VFP 10.
In deze commentaar zie je al verwijzen naar Gambas …

Installatie van Gambas v. 2 (alg)

Momenteel zijn de files versie 1.9x, maar functioneel is het versie 2.
Er staan voor een paar distributies beschrijvingen in de Gambas documentatie:
Voor de Debian-Ubuntu-achtigen bv hier http://gambasdoc.org/help/install/ubuntu?nl
(Zie ook install logs op deze site in de rubriek “installatie”)
Algemeen moet je eerst zorgen dat je de nodige componenten op je Linux systeem hebt
De lijst word gegeven in […]